Skip to content
pvmehta.com

pvmehta.com

  • Home
  • About Me
  • Toggle search form
  • V$INSTANCE of Oracle in MYSQL MYSQL
  • replace alphabets using sed Linux/Unix
  • All About oracle password and security from metalink Oracle
  • Library cahe Latches and internal explaination Oracle
  • get_vmstat_solaris Oracle
  • remove archfiles only when it is applied to DR rm_archfiles.sh Linux/Unix
  • Generate SSH without password authentication. Linux/Unix
  • pvm_metric.sql for gathering report from vmstat tables Oracle
  • New Latest Param.sql for finding all hidden parameters also Oracle
  • get_vmstat.ksh for Solaris Oracle
  • Global Unique Identifier Generation in Oracle 9.2 SYS_GUID() Oracle
  • plan10g.sql good1 Oracle
  • Removing first line Linux/Unix
  • handling filenname with space Linux/Unix
  • How to analyze statspack or AWR report. Oracle

Changing the Global Database Name

Posted on 07-Nov-2005 By Admin No Comments on Changing the Global Database Name

Changing the Global Database Name: Example The following statement changes the global name of the database and includes both the database name and domain: ALTER DATABASE RENAME GLOBAL_NAME TO demo.world.oracle.com;

Oracle, SQL scripts

Resolving RMAN Hung Jobs

Posted on 04-Nov-2005 By Admin No Comments on Resolving RMAN Hung Jobs

PURPOSE ======= This note discusses resolving an RMAN Hung Job SCOPE & APPLICATION =================== Anyone involved in running RMAN jobs Resolving an RMAN Hung Job ========================== Components of an RMAN Session The nature of an RMAN session depends on the operating system. In UNIX, an RMAN session has the following processes associated with it: –…

Read More “Resolving RMAN Hung Jobs” »

Oracle, rman-dataguard

Vivek Tuning for Row Locks.

Posted on 03-Nov-2005 By Admin No Comments on Vivek Tuning for Row Locks.

/************************ wait.sql *************************/ set pages 2000 set lines 132 column p1text format a18 column event format a35 column WT format 9999 column SW format 9999 select sid, event,p1text,p1raw,p1,p2,p3,seconds_in_Wait “SW”,Wait_time “WT” from v$session_wait where event not in( ‘KXFQ: Dequeue Range Keys – Slave’, ‘KXFQ: Dequeuing samples’, ‘KXFQ: kxfqcls – consumer closing TQ’, ‘KXFQ: kxfqdeq – dequeue…

Read More “Vivek Tuning for Row Locks.” »

Oracle, SQL scripts

Mutating Table Error while using database trigger

Posted on 03-Nov-2005 By Admin No Comments on Mutating Table Error while using database trigger

The Mutating table error is a well-known problem encountered in development; most developers have come across this error. ORA-04091: table is mutating, trigger/function may not see it The basic reason for this error is the way that Oracle manages a read consistent view of data. The error is encountered when a row-level trigger accesses the…

Read More “Mutating Table Error while using database trigger” »

Oracle, SQL scripts

Adding Datafile on Primary Server and Impact on Standby Server

Posted on 28-Oct-2005 By Admin No Comments on Adding Datafile on Primary Server and Impact on Standby Server

When u add a datafile in Primary then those changes are not immediately propagated to standby. Once Log with this changes applied to standby, standby database create a filename in $ORACLE_HOME/dbs. This is just a file name and does not have physical file. After this even all log apply service will fail as this is…

Read More “Adding Datafile on Primary Server and Impact on Standby Server” »

Oracle, rman-dataguard

USER_TABLES.Freelists

Posted on 28-Oct-2005 By Admin No Comments on USER_TABLES.Freelists

When you are using tablespace with segment space management AUTO then following command will not show FREELISTS. Alter table move tablespace my_data storage (initial 20M freelists 9) initrans 9; If tablespace is crreated with segment space management AUTO Then USER_TABLES.FREELISTS does not show FREELISTs as 9, but it displays blank in FREELISTS column.

Oracle, SQL scripts

My Test Case On 21-OCT-2005

Posted on 21-Oct-2005 By Admin No Comments on My Test Case On 21-OCT-2005

(*) if you grant any role to grantee while grantee is connected to database. He cannot use that role immediately. To use it immediately he needs to execute “Set role role_name” in his session. This will enable that role for him or he needs to logoff and login again. (*) If you have given any…

Read More “My Test Case On 21-OCT-2005” »

Oracle, SQL scripts

TABLE SIZING WITH DB_BLOCK ARCHITECTURE Reference : Metalink note : 10640.1

Posted on 14-Oct-2005 By Admin No Comments on TABLE SIZING WITH DB_BLOCK ARCHITECTURE Reference : Metalink note : 10640.1

=================================================================== STEP-I First, calculate the total block header size: =================================================================== block header = fixed header + variable transaction header + table directory + row directory where: fixed header = 57 bytes (the 4 bytes at the end of the block have already been taken account of in the 24 bytes for the cache header) variable…

Read More “TABLE SIZING WITH DB_BLOCK ARCHITECTURE Reference : Metalink note : 10640.1” »

Oracle, SQL scripts

FGA Part-I

Posted on 13-Oct-2005 By Admin No Comments on FGA Part-I

=========================================================================================================================================== Fine-Grained Auditing Part-I: Reference : from Arup Nanda on http://www.oracle.com/technology/oramag/webcolumns/2003/techarticles/nanda_fga.html ——————————————————————————————————————————————- (*) Traditional Oracle Database auditing options let you track the actions users perform on objects at the macro level for example, if you audit for SELECT statements on a table, you can track who selected data from the table. However, you don’t know…

Read More “FGA Part-I” »

Oracle, SQL scripts

Updated LCK.SQL file.

Posted on 13-Oct-2005 By Admin No Comments on Updated LCK.SQL file.

select c.sid, c.serial#, f.spid as osprocess, c.username, a.object_id, b.object_name, c.program, c.status, d.name, c.osuser, e.sql_text, DBMS_ROWID.ROWID_CREATE(1, c.ROW_WAIT_OBJ#, c.ROW_WAIT_FILE#, c.ROW_WAIT_BLOCK#, c.ROW_WAIT_ROW# ) locked_rowid from v$Locked_object a, All_objects b, v$session c, audit_actions d, v$sqlarea e, v$process f where a.object_id=b.data_object_id and a.session_id =c.sid(+) and c.command=d.action and c.row_wait_obj# != -1 and c.sql_id=e.sql_id and c.paddr = f.addr;

Oracle, SQL scripts

Posts pagination

Previous 1 … 46 47 48 … 59 Next

Categories

  • AMC10 (0)
  • Ansible (0)
  • AWS (2)
  • Azure (1)
  • Django (0)
  • GIT (1)
  • Linux/Unix (150)
  • MYSQL (5)
  • Oracle (403)
  • PHP/MYSQL/Wordpress (10)
  • POSTGRESQL (1)
  • Power-BI (0)
  • Python/PySpark (7)
  • RAC (18)
  • rman-dataguard (26)
  • shell (151)
  • SQL scripts (349)
  • SQL Server (6)
  • Uncategorized (6)
  • Videos (0)

Recent Posts

  • AMC1020-Sep-2026
  • Key Management in Oracle: The Core Issue: Missing Master Key12-May-2026
  • SAT Mathematics 10 questions and answer at the end.30-Apr-2026
  • top 10 AI news today30-Apr-2026
  • runon_allpdbs_show_conname.sh23-Apr-2026
  • runon_allcdbs_find_pdbs.sh23-Apr-2026
  • Running PDB on single node in RAC09-Apr-2026
  • find_arc.sql09-Apr-2026
  • pvm_pre_change.sql08-Apr-2026
  • find_encr_wallet.sql08-Apr-2026

Archives

  • 2026
  • 2025
  • 2024
  • 2023
  • 2010
  • 2009
  • 2008
  • 2007
  • 2006
  • 2005
  • AWR settings- MMON is not taking snapshot. Oracle
  • switchover for primary database Oracle
  • CPU speed on solaris Linux/Unix
  • note id 373303.1 Linux/Unix
  • Does DBMS_JOB recompute the NEXT_DATE interval after or before Oracle
  • replace alphabets using sed Linux/Unix
  • How to hide author name in WordPress BLOG PHP/MYSQL/Wordpress
  • CPU speed on Linux Linux/Unix

Copyright © 2026 pvmehta.com.

Powered by PressBook News WordPress theme